読者です 読者をやめる 読者になる 読者になる

labunix's blog

labunixのラボUnix

GNS3でOSPF(ネットワークタイプ:ブロードキャスト)の検証環境を構築してみる。

■GNS3でOSPF(ネットワークタイプ:ブロードキャスト)の検証環境を構築してみる。
 非常にシンプルな構成。

$ echo "[R1] -- f0/0-f0/0(192.168.1.0/30)OSPFArea0 --> \
        [R2] -- f1/0-f0/0(192.168.1.4/30)OSPFArea1 --> \
        [R3]" | \
    graph-easy --dot | dot -T png -o OSPF1.png

f:id:labunix:20160829012051p:plain
f:id:labunix:20160829012104p:plain

■GNS3の構成ファイルは以下

=> show run
autostart = False
[127.0.0.1:7200]
    workingdir = /tmp
    udp = 10001
    [[3620]]
        image = /Images/ios/c3620-is-mz.123-1.image
        ram = 128
        idlepc = 0x603d5308
        sparsemem = True
        ghostios = True
    [[ROUTER R1]]
        model = 3620
        console = 2101
        aux = 2501
        slot0 = NM-1FE-TX
        f0/0 = R2 f0/0
    [[ROUTER R2]]
        model = 3620
        console = 2102
        aux = 2502
        slot0 = NM-1FE-TX
        f0/0 = R1 f0/0
        slot1 = NM-1FE-TX
        f1/0 = R3 f0/0
    [[ROUTER R3]]
        model = 3620
        console = 2103
        aux = 2503
        slot0 = NM-1FE-TX
        f0/0 = R2 f1/0
=> 

■ルータの基本設定

$ for n in `seq 1 3`;do \
    echo -e "enable\nconfigure terminal\nhostname R${n}\nend\nwrite memory"; \
  done

■OSPF設定

! R1
configure terminal
  interface f0/0
    ip address 192.168.1.1 255.255.255.252
    no shutdown
  exit
  router ospf 1
  network 192.168.1.0 0.0.0.3 area 0
  end
write memory

! R2
configure terminal
  interface f0/0
    ip address 192.168.1.2 255.255.255.252
    no shutdown
  interface f1/0
    ip address 192.168.1.5 255.255.255.252
    no shutdown
  exit
  router ospf 1
  network 192.168.1.0 0.0.0.3 area 0
  network 192.168.1.4 0.0.0.3 area 1
  end
write memory

! R3
configure terminal
  interface f0/0
    ip address 192.168.1.6 255.255.255.252
    no shutdown
  exit
  router ospf 1
  network 192.168.1.4 0.0.0.3 area 1
  end
write memory

■OSPF設定の確認

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.5       1   FULL/BDR        00:00:34    192.168.1.2     FastEthernet0/0

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   FULL/BDR        00:00:39    192.168.1.1     FastEthernet0/0
192.168.1.6       1   FULL/DR         00:00:39    192.168.1.6     FastEthernet1/0

R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.5       1   FULL/BDR        00:00:32    192.168.1.5     FastEthernet0/0

■ルーティングテーブルの確認

R1#show ip route ospf 
     192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.4 [110/2] via 192.168.1.2, 00:03:10, FastEthernet0/0
R2#show ip route ospf 

R3#show ip route ospf 
     192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 192.168.1.5, 00:03:10, FastEthernet0/0

■デフォルトのタイマーの確認

R1#show ip ospf interface | include inter
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R2#show ip ospf interface | include inter
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R3#show ip ospf interface | include inter
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

■R1からR3、R3からR1にpingが通るようになったので、R2について詳細を確認する。

R2#show ip ospf neighbor detail 
 Neighbor 192.168.1.1, interface address 192.168.1.1
    In the area 0 via interface FastEthernet0/0 
    Neighbor priority is 1, State is FULL, 12 state changes
    DR is 192.168.1.2 BDR is 192.168.1.1
    Options is 0x52
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:38
    Neighbor is up for 00:05:24
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
 Neighbor 192.168.1.6, interface address 192.168.1.6
    In the area 1 via interface FastEthernet1/0 
    Neighbor priority is 1, State is FULL, 12 state changes
    DR is 192.168.1.5 BDR is 192.168.1.6
    Options is 0x52
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:37
    Neighbor is up for 00:05:24
    Index 1/1, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec

R2#show ip protocols 
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.1.5
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.1.0 0.0.0.3 area 0
    192.168.1.4 0.0.0.3 area 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.5          110      00:01:15
    192.168.1.6          110      00:06:05
  Distance: (default is 110)

R2#show ip ospf
 Routing Process "ospf 1" with ID 192.168.1.5
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 It is an area border router
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
	Number of interfaces in this area is 1
	Area has no authentication
	SPF algorithm last executed 00:01:38.376 ago
	SPF algorithm executed 5 times
	Area ranges are
	Number of LSA 4. Checksum Sum 0x03BD9E
	Number of opaque link LSA 0. Checksum Sum 0x000000
	Number of DCbitless LSA 0
	Number of indication LSA 0
	Number of DoNotAge LSA 0
	Flood list length 0
    Area 1
	Number of interfaces in this area is 1
	Area has no authentication
	SPF algorithm last executed 00:06:20.556 ago
	SPF algorithm executed 4 times
	Area ranges are
	Number of LSA 4. Checksum Sum 0x023871
	Number of opaque link LSA 0. Checksum Sum 0x000000
	Number of DCbitless LSA 0
	Number of indication LSA 0
	Number of DoNotAge LSA 0
	Flood list length 0

R2#show ip ospf interface 
FastEthernet0/0 is up, line protocol is up 
  Internet Address 192.168.1.2/30, Area 0 
  Process ID 1, Router ID 192.168.1.5, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 192.168.1.5, Interface address 192.168.1.2
  Backup Designated router (ID) 192.168.1.1, Interface address 192.168.1.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 192.168.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
FastEthernet1/0 is up, line protocol is up 
  Internet Address 192.168.1.5/30, Area 1 
  Process ID 1, Router ID 192.168.1.5, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 192.168.1.5, Interface address 192.168.1.5
  Backup Designated router (ID) 192.168.1.6, Interface address 192.168.1.6
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 192.168.1.6  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R2#show ip ospf database 

            OSPF Router with ID (192.168.1.5) (Process ID 1)

		Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.1.1     192.168.1.1     439         0x80000002 0x00FC86 1
192.168.1.5     192.168.1.5     439         0x80000005 0x00C7AE 1

		Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.2     192.168.1.5     439         0x80000001 0x009CE9

		Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.4     192.168.1.5     429         0x80000006 0x0061FA

		Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.1.5     192.168.1.5     429         0x80000005 0x001060 1
192.168.1.6     192.168.1.6     436         0x80000005 0x000B63 1

		Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.5     192.168.1.5     439         0x80000001 0x00C4B9

		Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.0     192.168.1.5     441         0x80000004 0x008DD4

R2#show ip ospf database router 

            OSPF Router with ID (192.168.1.5) (Process ID 1)

		Router Link States (Area 0)

  LS age: 358
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 192.168.1.1
  Advertising Router: 192.168.1.1
  LS Seq Number: 80000004
  Checksum: 0xEE93
  Length: 36
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.1
     (Link Data) Router Interface address: 192.168.1.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 1


  LS age: 353
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 192.168.1.5
  Advertising Router: 192.168.1.5
  LS Seq Number: 80000006
  Checksum: 0xBBBA
  Length: 36
  Area Border Router
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.1
     (Link Data) Router Interface address: 192.168.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 1



		Router Link States (Area 1)

  LS age: 349
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 192.168.1.5
  Advertising Router: 192.168.1.5
  LS Seq Number: 80000006
  Checksum: 0x1856
  Length: 36
  Area Border Router
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.6
     (Link Data) Router Interface address: 192.168.1.5
      Number of TOS metrics: 0
       TOS 0 Metrics: 1


  LS age: 360
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 192.168.1.6
  Advertising Router: 192.168.1.6
  LS Seq Number: 80000007
  Checksum: 0x115A
  Length: 36
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.6
     (Link Data) Router Interface address: 192.168.1.6
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

R2#show ip ospf database network 

            OSPF Router with ID (192.168.1.5) (Process ID 1)

		Net Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 450
  Options: (No TOS-capability, DC)
  LS Type: Network Links
  Link State ID: 192.168.1.1 (address of Designated Router)
  Advertising Router: 192.168.1.1
  LS Seq Number: 80000001
  Checksum: 0xCEBC
  Length: 32
  Network Mask: /30
	Attached Router: 192.168.1.1
	Attached Router: 192.168.1.5


		Net Link States (Area 1)

  Routing Bit Set on this LSA
  LS age: 447
  Options: (No TOS-capability, DC)
  LS Type: Network Links
  Link State ID: 192.168.1.6 (address of Designated Router)
  Advertising Router: 192.168.1.6
  LS Seq Number: 80000001
  Checksum: 0xB0CB
  Length: 32
  Network Mask: /30
	Attached Router: 192.168.1.6
	Attached Router: 192.168.1.5

	
R2#show ip ospf database summary 

            OSPF Router with ID (192.168.1.5) (Process ID 1)

		Summary Net Link States (Area 0)

  LS age: 462
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.1.4 (summary Network Number)
  Advertising Router: 192.168.1.5
  LS Seq Number: 80000007
  Checksum: 0x5FFB
  Length: 28
  Network Mask: /30
	TOS: 0 	Metric: 1 


		Summary Net Link States (Area 1)

  LS age: 462
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.1.0 (summary Network Number)
  Advertising Router: 192.168.1.5
  LS Seq Number: 80000005
  Checksum: 0x8BD5
  Length: 28
  Network Mask: /30
	TOS: 0 	Metric: 1 


R2#debug ip ospf hello 
OSPF hello events debugging is on
*Mar  1 00:39:32.427: OSPF: Rcv hello from 192.168.1.1 area 0 from FastEthernet0/0 192.168.1.1
*Mar  1 00:39:32.427: OSPF: End of hello processing
*Mar  1 00:39:33.411: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0 from 192.168.1.2
*Mar  1 00:39:33.411: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet1/0 from 192.168.1.5
*Mar  1 00:39:33.539: OSPF: Rcv hello from 192.168.1.6 area 1 from FastEthernet1/0 192.168.1.6
*Mar  1 00:39:33.539: OSPF: End of hello processing
*Mar  1 00:39:42.603: OSPF: Rcv hello from 192.168.1.1 area 0 from FastEthernet0/0 192.168.1.1
*Mar  1 00:39:42.603: OSPF: End of hello processing
*Mar  1 00:39:43.411: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0 from 192.168.1.2
*Mar  1 00:39:43.411: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet1/0 from 192.168.1.5
*Mar  1 00:39:43.979: OSPF: Rcv hello from 192.168.1.6 area 1 from FastEthernet1/0 192.168.1.6
*Mar  1 00:39:43.979: OSPF: End of hello processing
R2#no debug ip ospf hello
OSPF hello events debugging is off

R2#debug ip ospf adj 
OSPF adjacency events debugging is on
R2#clear ip ospf process 
Reset ALL OSPF processes? [no]: yes
R2#
*Mar  1 00:41:21.659: OSPF: Interface FastEthernet0/0 going Down
*Mar  1 00:41:21.659: OSPF: 192.168.1.5 address 192.168.1.2 on FastEthernet0/0 is dead, state DOWN
*Mar  1 00:41:21.659: OSPF: Neighbor change Event on interface FastEthernet0/0
*Mar  1 00:41:21.659: OSPF: DR/BDR election on FastEthernet0/0 
*Mar  1 00:41:21.659: OSPF: Elect BDR 192.168.1.1
*Mar  1 00:41:21.659: OSPF: Elect DR 192.168.1.1
*Mar  1 00:41:21.663: OSPF: Elect BDR 192.168.1.1
*Mar  1 00:41:21.663: OSPF: Elect DR 192.168.1.1
*Mar  1 00:41:21.663:        DR: 192.168.1.1 (Id)   BDR: 192.168.1.1 (Id)
*Mar  1 00:41:21.663: OSPF: Flush network LSA immediately
*Mar  1 00:41:21.663: OSPF: Remember old DR 192.168.1.5 (id)
*Mar  1 00:41:21.663: OSPF: 192.168.1.1 address 192.168.1.1 on FastEthernet0/0 is dead, state DOWN
*Mar  1 00:41:21.667: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:41:21.667: OSPF: Neighbor change Event on interface FastEthernet0/0
*Mar  1 00:41:21.667: OSPF: DR/BDR election on FastEthernet0/0 
*Mar  1 00:41:21.667: OSPF: Elect BDR 0.0.0.0
*Mar  1 00:41:21.671: OSPF: Elect DR 0.0.0.0
*Mar  1 00:41:21.671:        DR: none    BDR: none 
*Mar  1 00:41:21.671: OSPF: Remember old DR 192.168.1.1 (id)
*Mar  1 00:41:21.711: OSPF: Interface FastEthernet1/0 going Down
*Mar  1 00:41:21.711: OSPF: 192.168.1.5 address 192.168.1.5 on FastEthernet1/0 is dead, state DOWN
*Mar  1 00:41:21.711: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar  1 00:41:21.711: OSPF: DR/BDR election on FastEthernet1/0 
*Mar  1 00:41:21.711: OSPF: Elect BDR 192.168.1.6
*Mar  1 00:41:21.711: OSPF: Elect DR 192.168.1.6
*Mar  1 00:41:21.715: OSPF: Elect BDR 192.168.1.6
*Mar  1 00:41:21.715: OSPF: Elect DR 192.168.1.6
*Mar  1 00:41:21.715:        DR: 192.168.1.6 (Id)   BDR: 192.168.1.6 (Id)
*Mar  1 00:41:21.715: OSPF: Flush network LSA immediately
*Mar  1 00:41:21.715: OSPF: Remember old DR 192.168.1.5 (id)
*Mar  1 00:41:21.715: OSPF: 192.168.1.6 address 192.168.1.6 on FastEthernet1/0 is dead, state DOWN
*Mar  1 00:41:21.719: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.6 on FastEthernet1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:41:21.719: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar  1 00:41:21.719: OSPF: DR/BDR election on FastEthernet1/0 
*Mar  1 00:41:21.719: OSPF: Elect BDR 0.0.0.0
*Mar  1 00:41:21.723: OSPF: Elect DR 0.0.0.0
*Mar  1 00:41:21.723:        DR: none    BDR: none 
*Mar  1 00:41:21.723: OSPF: Remember old DR 192.168.1.6 (id)
*Mar  1 00:41:21.791: OSPF: Interface FastEthernet0/0 going Up
*Mar  1 00:41:21.791: OSPF: Interface FastEthernet1/0 going Up
*Mar  1 00:41:22.163: OSPF: We are not DR to build Net Lsa for interface FastEthernet0/0
*Mar  1 00:41:22.163: OSPF: Build router LSA for area 0, router ID 192.168.1.5, seq 0x80000001
*Mar  1 00:41:22.215: OSPF: We are not DR to build Net Lsa for interface FastEthernet1/0
*Mar  1 00:41:22.215: OSPF: Build router LSA for area 1, router ID 192.168.1.5, seq 0x80000001
*Mar  1 00:41:27.319: OSPF: 2 Way Communication to 192.168.1.1 on FastEthernet0/0, state 2WAY
*Mar  1 00:41:27.319: OSPF: Backup seen Event before WAIT timer on FastEthernet0/0
*Mar  1 00:41:27.319: OSPF: DR/BDR election on FastEthernet0/0 
*Mar  1 00:41:27.319: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:27.319: OSPF: Elect DR 192.168.1.1
*Mar  1 00:41:27.323: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:27.323: OSPF: Elect DR 192.168.1.1
*Mar  1 00:41:27.323:        DR: 192.168.1.1 (Id)   BDR: 192.168.1.5 (Id)
*Mar  1 00:41:27.323: OSPF: Send DBD to 192.168.1.1 on FastEthernet0/0 seq 0x18B0 opt 0x52 flag 0x7 len 32
*Mar  1 00:41:27.339: OSPF: Rcv DBD from 192.168.1.1 on FastEthernet0/0 seq 0x1AA1 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  1 00:41:27.339: OSPF: First DBD and we are not SLAVE
*Mar  1 00:41:27.339: OSPF: Rcv DBD from 192.168.1.1 on FastEthernet0/0 seq 0x18B0 opt 0x52 flag 0x2 len 72  mtu 1500 state EXSTART
*Mar  1 00:41:27.343: OSPF: NBR Negotiation Done. We are the MASTER
*Mar  1 00:41:27.343: OSPF: Send DBD to 192.168.1.1 on FastEthernet0/0 seq 0x18B1 opt 0x52 flag 0x3 len 72
*Mar  1 00:41:27.343: OSPF: Database request to 192.168.1.1 
*Mar  1 00:41:27.343: OSPF: sent LS REQ packet to 192.168.1.1, length 24
*Mar  1 00:41:27.359: OSPF: Rcv DBD from 192.168.1.1 on FastEthernet0/0 seq 0x18B1 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:41:27.359: OSPF: Send DBD to 192.168.1.1 on FastEthernet0/0 seq 0x18B2 opt 0x52 flag 0x1 len 32
*Mar  1 00:41:27.383: OSPF: Rcv DBD from 192.168.1.1 on FastEthernet0/0 seq 0x18B2 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:41:27.383: OSPF: Exchange Done with 192.168.1.1 on FastEthernet0/0
*Mar  1 00:41:27.383: OSPF: Synchronized with 192.168.1.1 on FastEthernet0/0, state FULL
*Mar  1 00:41:27.383: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Mar  1 00:41:27.827: OSPF: Build router LSA for area 0, router ID 192.168.1.5, seq 0x80000002
*Mar  1 00:41:30.415: OSPF: 2 Way Communication to 192.168.1.6 on FastEthernet1/0, state 2WAY
*Mar  1 00:41:30.415: OSPF: Backup seen Event before WAIT timer on FastEthernet1/0
*Mar  1 00:41:30.415: OSPF: DR/BDR election on FastEthernet1/0 
*Mar  1 00:41:30.419: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:30.419: OSPF: Elect DR 192.168.1.6
*Mar  1 00:41:30.419: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:30.419: OSPF: Elect DR 192.168.1.6
*Mar  1 00:41:30.419:        DR: 192.168.1.6 (Id)   BDR: 192.168.1.5 (Id)
*Mar  1 00:41:30.419: OSPF: Send DBD to 192.168.1.6 on FastEthernet1/0 seq 0x1C27 opt 0x52 flag 0x7 len 32
*Mar  1 00:41:30.435: OSPF: Rcv DBD from 192.168.1.6 on FastEthernet1/0 seq 0x258C opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  1 00:41:30.435: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  1 00:41:30.435: OSPF: Send DBD to 192.168.1.6 on FastEthernet1/0 seq 0x258C opt 0x52 flag 0x2 len 72
*Mar  1 00:41:30.455: OSPF: Rcv DBD from 192.168.1.6 on FastEthernet1/0 seq 0x258D opt 0x52 flag 0x3 len 72  mtu 1500 state EXCHANGE
*Mar  1 00:41:30.455: OSPF: Send DBD to 192.168.1.6 on FastEthernet1/0 seq 0x258D opt 0x52 flag 0x0 len 32
*Mar  1 00:41:30.459: OSPF: Database request to 192.168.1.6 
*Mar  1 00:41:30.459: OSPF: sent LS REQ packet to 192.168.1.6, length 24
*Mar  1 00:41:30.475: OSPF: Rcv DBD from 192.168.1.6 on FastEthernet1/0 seq 0x258E opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:41:30.475: OSPF: Exchange Done with 192.168.1.6 on FastEthernet1/0
*Mar  1 00:41:30.475: OSPF: Send DBD to 192.168.1.6 on FastEthernet1/0 seq 0x258E opt 0x52 flag 0x0 len 32
*Mar  1 00:41:30.479: OSPF: Synchronized with 192.168.1.6 on FastEthernet1/0, state FULL
*Mar  1 00:41:30.479: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.6 on FastEthernet1/0 from LOADING to FULL, Loading Done
*Mar  1 00:41:30.923: OSPF: Build router LSA for area 1, router ID 192.168.1.5, seq 0x80000002
*Mar  1 00:41:32.839: OSPF: Build router LSA for area 0, router ID 192.168.1.5, seq 0x80000006
*Mar  1 00:41:36.127: OSPF: Neighbor change Event on interface FastEthernet0/0
*Mar  1 00:41:36.127: OSPF: DR/BDR election on FastEthernet0/0 
*Mar  1 00:41:36.127: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:36.127: OSPF: Elect DR 192.168.1.1
*Mar  1 00:41:36.127:        DR: 192.168.1.1 (Id)   BDR: 192.168.1.5 (Id)
*Mar  1 00:41:36.935: OSPF: Build router LSA for area 1, router ID 192.168.1.5, seq 0x80000006
*Mar  1 00:41:39.291: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar  1 00:41:39.291: OSPF: DR/BDR election on FastEthernet1/0 
*Mar  1 00:41:39.291: OSPF: Elect BDR 192.168.1.5
*Mar  1 00:41:39.291: OSPF: Elect DR 192.168.1.6
*Mar  1 00:41:39.291:        DR: 192.168.1.6 (Id)   BDR: 192.168.1.5 (Id)
R2#
R2#no debug ip ospf adj
OSPF adjacency events debugging is off