labunix's blog

labunixのラボUnix

(GNS3)IOUでL2 Port-channelを試してみる。

(GNS3)IOUでL2 Port-channelを試してみる。
 以下c3725のIOU版

 GNS3でL2のPortChannelを作成してみる。
 http://labunix.hateblo.jp/entry/20160507/1462563152

■IOU L2 15.1aを2台、「add Link」で e3/2-3を接続。

int range e 3/2-3
 duplex full
 switchport
 switchport trunk encapsulation dot1q 
 switchport mode trunk 
 switchport trunk allowed vlan 100,200
 channel-group 1 mode on
 no shut
 end
write 

CiscoIOUL215.1a-1#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Et3/2(P)    Et3/3(P)    

CiscoIOUL215.1a-1#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Et3/2(P)    Et3/3(P)    

CiscoIOUL215.1a-1#show etherchannel         
		Channel-group listing: 
		----------------------

Group: 1 
----------
Group state = L2 
Ports: 2   Maxports = 4
Port-channels: 1 Max Port-channels = 1
Protocol:    -
Minimum Links: 0


■vlan100でping疎通確認

conf t
 vlan 100
   name TEST100
 int Vlan100
   ip address 192.168.100.1 255.255.255.252
   no shut
 end
write mem

conf t
 vlan 100
   name TEST100
 int Vlan100
   ip address 192.168.100.2 255.255.255.252
   no shut
 end
write mem

CiscoIOUL215.1a-1#show interfaces summary | inc 3/[23]|Po
* Ethernet3/2                   0         0         0         0         0         0         0         0         0
* Ethernet3/3                   0         0         0         0         0         0         0         0         0
* Port-channel1                 0         0         0         0         0         0         0         0         0

CiscoIOUL215.1a-2#show interfaces summary | inc 3/[23]|Po 
* Ethernet3/2                   0         0         0         0         0         0         0         0         0
* Ethernet3/3                   0         0         0         0         0         0         0         0         0
* Port-channel1                 0         0         0         0         0         0         0         0         0


CiscoIOUL215.1a-2#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

CiscoIOUL215.1a-1#ping 192.168.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

CiscoIOUL215.1a-1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32868
             Address     aabb.cc00.0100
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po1                 Desg FWD 56        128.65   Shr 


CiscoIOUL215.1a-1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/30 is directly connected, Vlan100
L        192.168.100.1/32 is directly connected, Vlan100

CiscoIOUL215.1a-2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/30 is directly connected, Vlan100
L        192.168.100.2/32 is directly connected, Vlan100