labunix's blog

labunixのラボUnix

Cisco IOU L3/L2環境を整理してみる。

■Cisco IOU L3/L2環境を整理してみる。
 台数も増えてきたので、最終的に以下のように、
 16GBから8GBメモリのホストに移行するためのダイエットをする。

■16GBホスト(別途IOU L3を4台、L2を1台追加している環境なので若干構成が異なる)

cpu:4.2 i86bi-linux-l2-ipbasek9-15.1g.bin
cpu:26.1 i86bi-linux-l3-adventerprisek9-15.5.2T.bin
CPU Total:30.3

mem:1 i86bi-linux-l2-ipbasek9-15.1g.bin
mem:29.4 i86bi-linux-l3-adventerprisek9-15.5.2T.bin
MEM Total:30.4

cnt:2 i86bi-linux-l2-ipbasek9-15.1g.bin
cnt:21 i86bi-linux-l3-adventerprisek9-15.5.2T.bin
CNT Total:23

■8GBホスト(15台稼働してもメモリ使用率50%以下で安定している)

$ ps axo pcpu,pmem,pid,cmd | \
    awk '/IOU/&&!/awk/{gsub("/home.*/IOU/","",$0);a[$4]+=$1;b[$4]+=$2;c[$4]+=1} \
      END{for(n in a){cpu+=a[n];print "cpu:"a[n],n}{print "CPU Total:"cpu"\n"} \
          for(n in b){mem+=b[n];print "mem:"b[n],n}{print "MEM Total:"mem"\n"} \
          for(n in c){cnt+=c[n];print "cnt:"c[n],n}{print "CNT Total:"cnt}}'
cpu:2.4 i86bi-linux-l2-ipbasek9-15.1g.bin
cpu:22.4 i86bi-linux-l3-adventerprisek9-ms.155-2.T.bin
CPU Total:24.8

mem:1.1 i86bi-linux-l2-ipbasek9-15.1g.bin
mem:40.6 i86bi-linux-l3-adventerprisek9-ms.155-2.T.bin
MEM Total:41.7

cnt:1 i86bi-linux-l2-ipbasek9-15.1g.bin
cnt:14 i86bi-linux-l3-adventerprisek9-ms.155-2.T.bin
CNT Total:15

f:id:labunix:20180820004741p:plain

■ダミーNICは以下のように変更

$ sudo grep -A 12 br1 /etc/network/interfaces
auto br1
iface br1 inet static
	address 192.168.1.5
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	bridge_ports none
	bridge_stp off
	bridge_fd 0
	bridge_maxwait 0
        up route add -net 172.16.14.0/24 gw 192.168.1.11

■IOU L2を排除、IOU L3のSerial/EThernet共に2から1に、管理LANを削除

 Cisco IOU L3でEIGRP検証環境を作ってみる。
 http://labunix.hateblo.jp/entry/20180725/1532448140

EIGRP-R1#show run | section Serial1/0
interface Serial1/0
 ip address 172.16.14.11 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0

EIGRP-R2#show run | section Serial1/0
interface Serial1/0
 ip address 172.16.14.12 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0

EIGRP-R3#show run | section Serial1/0 
interface Serial1/0
 ip address 172.16.14.13 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0

■EIGRP 65001を構成。EIGRP-R1のみ「passive-interface」設定あり。

EIGRP-R1#show run | section router
router eigrp 65001
 network 172.16.14.0 0.0.0.255
 network 192.168.1.0 0.0.0.255
 passive-interface Ethernet0/0

■フレームマップの状態確認

EIGRP-R1#show frame-relay map 
Serial1/0 (up): ip 172.16.14.12 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 172.16.14.13 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active

EIGRP-R2#show frame-relay map 
Serial1/0 (up): ip 172.16.14.11 dlci 201(0xC9,0x3090), dynamic,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.14.13 dlci 203(0xCB,0x30B0), dynamic,
              broadcast,
              CISCO, status defined, active

EIGRP-R3#show frame-relay map 
Serial1/0 (up): ip 172.16.14.11 dlci 301(0x12D,0x48D0), dynamic,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.14.12 dlci 302(0x12E,0x48E0), dynamic,
              broadcast,, status defined, active

■EIGRPルーティングの確認

EIGRP-R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.14.0/24 is directly connected, Serial1/0
L        172.16.14.11/32 is directly connected, Serial1/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/0
L        192.168.1.11/32 is directly connected, Ethernet0/0

EIGRP-R2#show ip route | inc /
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.14.0/24 is directly connected, Serial1/0
L        172.16.14.12/32 is directly connected, Serial1/0
D     192.168.1.0/24 [90/2195456] via 172.16.14.11, 00:03:47, Serial1/0

EIGRP-R3#show ip route | inc /
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.14.0/24 is directly connected, Serial1/0
L        172.16.14.13/32 is directly connected, Serial1/0
D     192.168.1.0/24 [90/2195456] via 172.16.14.11, 00:04:11, Serial1/0

EIGRP-R2#ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/8/10 ms

■SWを排除、IOU L3のSerial/EThernet共に2から1または0に、管理LANを削除、Ov3R1を削除

 IOU L3を使ったOSPFv3 (IPv6)検証環境を追加する。
 http://labunix.hateblo.jp/entry/20180805/1533426202

EIGRP-R1#show run | section Lo|ipv6|0/1|1/0
ipv6 unicast-routing
ipv6 cef
interface Loopback0
 no ip address
 ipv6 address FE0:1::1/128
 ipv6 enable
 ipv6 ospf 1 area 0
 ipv6 ospf network point-to-point
interface Ethernet0/1
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 0
interface Serial1/0
 ip address 172.16.14.11 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
ipv6 router ospf 1
 router-id 1.1.1.1

OSPFv3-2#show run | section Lo|ipv6|0/1|1/0
ipv6 unicast-routing
ipv6 cef
interface Loopback0
 no ip address
 ipv6 address FEC0:2::2/128
 ipv6 enable
 ipv6 ospf network point-to-point
interface Ethernet0/1
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 0
interface Serial1/0
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 23
 serial restart-delay 0
ipv6 router ospf 1
 router-id 2.2.2.2
 area 23 virtual-link 3.3.3.3

OSPFv3-3#show run | section Lo|ipv6|0/1|1/0
ipv6 unicast-routing
ipv6 cef
interface Loopback0
 no ip address
 ipv6 address FEC0:3::3/128
 ipv6 enable
 ipv6 ospf network point-to-point
interface Ethernet0/1
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 34
interface Serial1/0
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 23
 serial restart-delay 0
ipv6 router ospf 1
 router-id 3.3.3.3
 area 23 virtual-link 2.2.2.2

OSPFv3-4#show run | section Lo|ipv6|0/1|1/0
ipv6 unicast-routing
ipv6 cef
interface Loopback0
 no ip address
 ipv6 address FEC0:4::4/128
 ipv6 enable
 ipv6 ospf 1 area 34
 ipv6 ospf network point-to-point
interface Ethernet0/1
 no ip address
 ipv6 enable
 ipv6 ospf 1 area 34
ipv6 router ospf 1
 router-id 4.4.4.4

■ipv6 routeの確認

EIGRP-R1#show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt
       lr - LISP site-registrations, ld - LISP dyn-eid, a - Application
LC  FE0:1::1/128 [0/0]
     via Loopback0, receive
OI  FEC0:2::2/128 [110/10]
     via FE80::A8BB:CCFF:FE00:510, Ethernet0/1
OI  FEC0:3::3/128 [110/74]
     via FE80::A8BB:CCFF:FE00:510, Ethernet0/1
OI  FEC0:4::4/128 [110/84]
     via FE80::A8BB:CCFF:FE00:510, Ethernet0/1
L   FF00::/8 [0/0]
     via Null0, receive

OSPFv3-2#show ipv6 route | inc /|via
O   FE0:1::1/128 [110/10]
     via FE80::A8BB:CCFF:FE00:310, Ethernet0/1
LC  FEC0:2::2/128 [0/0]
     via Loopback0, receive
O   FEC0:3::3/128 [110/64]
     via FE80::A8BB:CCFF:FE00:600, Serial1/0
OI  FEC0:4::4/128 [110/74]
     via FE80::A8BB:CCFF:FE00:600, Serial1/0
L   FF00::/8 [0/0]
     via Null0, receive

OSPFv3-3#show ipv6 route | inc /|via
O   FE0:1::1/128 [110/74]
     via FE80::A8BB:CCFF:FE00:500, Serial1/0
O   FEC0:2::2/128 [110/64]
     via FE80::A8BB:CCFF:FE00:500, Serial1/0
LC  FEC0:3::3/128 [0/0]
     via Loopback0, receive
O   FEC0:4::4/128 [110/10]
     via FE80::A8BB:CCFF:FE00:710, Ethernet0/1
L   FF00::/8 [0/0]
     via Null0, receive

OSPFv3-4#show ipv6 route | inc /|via
OI  FE0:1::1/128 [110/84]
     via FE80::A8BB:CCFF:FE00:610, Ethernet0/1
OI  FEC0:2::2/128 [110/74]
     via FE80::A8BB:CCFF:FE00:610, Ethernet0/1
OI  FEC0:3::3/128 [110/10]
     via FE80::A8BB:CCFF:FE00:610, Ethernet0/1
LC  FEC0:4::4/128 [0/0]
     via Loopback0, receive
L   FF00::/8 [0/0]
     via Null0, receive

EIGRP-R1#tra ipv6 FEC0:4::4
Type escape sequence to abort.
Tracing the route to FEC0:4::4

  1 FEC0:2::2 0 msec 0 msec 1 msec
  2 FEC0:3::3 9 msec 9 msec 9 msec
  3 FEC0:4::4 9 msec 9 msec 10 msec

■SWをIOU L2に置き換え、IOU L3/L2のSerial/EThernet共に2から1に、管理LANを削除、R1を削除

 Cisco IOU L3でEIGRPスタブ検証環境を追加する。
 http://labunix.hateblo.jp/entry/20180731/1533029325

EIGRP-R2#show run | section 0/0|1/1|65000
interface Ethernet0/0
 no ip address
 shutdown
interface Serial1/1
 ip address 10.2.1.1 255.255.255.0
 serial restart-delay 0
 passive-interface Serial1/1
router eigrp 65000
 network 10.2.0.0 0.0.255.255
 network 172.16.1.0 0.0.0.255
 passive-interface Serial1/0
 eigrp stub receive-only

EIGRP-STUB2#show run | section 0/0|1/1|65000
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
interface Serial1/1
 ip address 10.2.1.2 255.255.255.0
 serial restart-delay 0
router eigrp 65000
 network 10.2.0.0 0.0.255.255
 network 172.16.1.0 0.0.0.255

EIGRP-STUB3#show run | section 0/0|1/1|65000
interface Ethernet0/0
 ip address 172.16.1.1 255.255.255.0
interface Serial1/1
 ip address 10.2.3.3 255.255.255.0
 serial restart-delay 0
router eigrp 65000
 network 10.2.0.0 0.0.255.255
 network 172.16.1.0 0.0.0.255
 passive-interface Ethernet0/0
 eigrp stub connected summary

EIGRP-STUB4#show run | section 0/0|1/1|65000
interface Ethernet0/0
 ip address 10.2.2.4 255.255.255.0
interface Serial1/1
 ip address 10.2.3.4 255.255.255.0
 ip summary-address eigrp 65000 10.2.0.0 255.255.0.0
 serial restart-delay 0
router eigrp 65000
 network 10.2.0.0 0.0.255.255
 network 172.16.1.0 0.0.0.255

L2SW#show run | section Vlan|0/0|route  
interface Ethernet0/0
 duplex auto
interface Vlan1
 ip address 172.16.1.2 255.255.255.0
ip route 10.2.0.0 255.255.0.0 172.16.1.1

■スタブの確認

EIGRP-R2#show ip eigrp 65000 neighbors detail 
EIGRP-IPv4 Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.2.1.2                Se1/1                    11 00:03:14   17   102  0  12
   Version 18.0/2.0, Retrans: 0, Retries: 0, Prefixes: 3
   Topology-ids from peer - 0 
Max Nbrs: 0, Current Nbrs: 0

EIGRP-STUB2#show ip eigrp 65000 neighbors detail 
EIGRP-IPv4 Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.2.1.1                Se1/1                    10 00:03:27   19   114  0  4
   Version 18.0/2.0, Retrans: 0, Retries: 0
   Topology-ids from peer - 0 
   Receive-Only Peer Advertising (No) Routes
   Suppressing queries
0   10.2.2.4                Et0/0                    11 00:05:20  819  4914  0  11
   Version 18.0/2.0, Retrans: 1, Retries: 0, Prefixes: 2
   Topology-ids from peer - 0 
Max Nbrs: 0, Current Nbrs: 0

EIGRP-STUB3#show ip eigrp 65000 neighbors detail 
EIGRP-IPv4 Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.2.3.4                Se1/1                    14 00:03:00   14   100  0  12
   Version 18.0/2.0, Retrans: 0, Retries: 0, Prefixes: 1
   Topology-ids from peer - 0 
Max Nbrs: 0, Current Nbrs: 0

EIGRP-STUB4#show ip eigrp 65000 neighbors detail 
EIGRP-IPv4 Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.2.3.3                Se1/1                    13 00:03:04   21   126  0  5
   Version 18.0/2.0, Retrans: 0, Retries: 0, Prefixes: 1
   Topology-ids from peer - 0 
   Stub Peer Advertising (CONNECTED SUMMARY ) Routes
   Suppressing queries
1   10.2.2.2                Et0/0                    10 00:05:32    2   100  0  11
   Version 18.0/2.0, Retrans: 1, Retries: 0, Prefixes: 1
   Topology-ids from peer - 0 
Max Nbrs: 0, Current Nbrs: 0

■スタブルーティングの確認

EIGRP-R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.2.1.0/24 is directly connected, Serial1/1
L        10.2.1.1/32 is directly connected, Serial1/1
D        10.2.2.0/24 [90/2195456] via 10.2.1.2, 00:15:09, Serial1/1
D        10.2.3.0/24 [90/2707456] via 10.2.1.2, 00:15:09, Serial1/1
      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D        172.16.1.0/24 [90/2733056] via 10.2.1.2, 00:14:34, Serial1/1
C        172.16.14.0/24 is directly connected, Serial1/0
L        172.16.14.12/32 is directly connected, Serial1/0
D     192.168.1.0/24 [90/2195456] via 172.16.14.11, 01:10:36, Serial1/0

EIGRP-STUB2#show ip route | inc /
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.2.1.0/24 is directly connected, Serial1/1
L        10.2.1.2/32 is directly connected, Serial1/1
C        10.2.2.0/24 is directly connected, Ethernet0/0
L        10.2.2.2/32 is directly connected, Ethernet0/0
D        10.2.3.0/24 [90/2195456] via 10.2.2.4, 00:18:12, Ethernet0/0
      172.16.0.0/24 is subnetted, 1 subnets
D        172.16.1.0 [90/2221056] via 10.2.2.4, 00:15:46, Ethernet0/0

EIGRP-STUB3#show ip route | inc /
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D        10.2.0.0/16 [90/2195456] via 10.2.3.4, 00:16:00, Serial1/1
C        10.2.3.0/24 is directly connected, Serial1/1
L        10.2.3.3/32 is directly connected, Serial1/1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, Ethernet0/0
L        172.16.1.1/32 is directly connected, Ethernet0/0

EIGRP-STUB4#show ip route | inc /
      10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D        10.2.0.0/16 is a summary, 00:19:28, Null0
D        10.2.1.0/24 [90/2195456] via 10.2.2.2, 00:18:27, Ethernet0/0
C        10.2.2.0/24 is directly connected, Ethernet0/0
L        10.2.2.4/32 is directly connected, Ethernet0/0
C        10.2.3.0/24 is directly connected, Serial1/1
L        10.2.3.4/32 is directly connected, Serial1/1
      172.16.0.0/24 is subnetted, 1 subnets
D        172.16.1.0 [90/2195456] via 10.2.3.3, 00:16:01, Serial1/1

EIGRP-R2#traceroute 172.16.1.2
Type escape sequence to abort.
Tracing the route to 172.16.1.2
VRF info: (vrf in name/id, vrf out name/id)
  1 10.2.1.2 9 msec 9 msec 9 msec
  2 10.2.2.4 10 msec 9 msec 4 msec
  3 10.2.3.3 18 msec 15 msec 17 msec
  4 172.16.1.2 18 msec 18 msec 18 msec

■SWを削除、IOU L3/L2のSerialを2から0に、EThernetを2から1に、管理LANを削除、R1を削除

 EIGRPの負荷分散検証環境を追加する。
 http://labunix.hateblo.jp/entry/20180802/1533221002

EIGRP-R3#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.1 255.255.255.255
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
interface Ethernet0/1
 ip address 192.168.13.1 255.255.255.0
router eigrp 65002
 distribute-list 8 out Ethernet0/0
 variance 2
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255
 passive-interface Serial1/0
access-list 8 deny   192.168.1.0 0.0.0.255
access-list 8 permit 192.168.0.0 0.0.255.255

RP2#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.2 255.255.255.255
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
interface Ethernet0/1
 ip address 192.168.24.2 255.255.255.0
router eigrp 65002
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255

RP3#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.3 255.255.255.255
interface Ethernet0/0
 ip address 192.168.35.3 255.255.255.0
interface Ethernet0/1
 ip address 192.168.13.3 255.255.255.0
router eigrp 65002
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255

RP4#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.4 255.255.255.255
interface Ethernet0/0
 ip address 192.168.46.4 255.255.255.0
interface Ethernet0/1
 ip address 192.168.24.4 255.255.255.0
router eigrp 65002
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255

RP5#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.5 255.255.255.255
interface Ethernet0/0
 ip address 192.168.35.5 255.255.255.0
interface Ethernet0/1
 ip address 192.168.56.5 255.255.255.0
router eigrp 65002
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255

RP6#show run | section Lo|0/0|0/1|65002|access
interface Loopback0
 ip address 10.6.6.6 255.255.255.255
interface Ethernet0/0
 ip address 192.168.46.6 255.255.255.0
interface Ethernet0/1
 ip address 192.168.56.6 255.255.255.0
router eigrp 65002
 network 10.6.6.0 0.0.0.255
 network 192.168.0.0 0.0.255.255

■ルーティングの確認

EIGRP-R3#show ip route eigrp 65002
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 6 subnets
D        10.6.6.2 [90/409600] via 192.168.12.2, 00:12:05, Ethernet0/0
D        10.6.6.3 [90/409600] via 192.168.13.3, 00:02:17, Ethernet0/1
D        10.6.6.4 [90/435200] via 192.168.12.2, 00:11:09, Ethernet0/0
D        10.6.6.5 [90/435200] via 192.168.13.3, 00:02:17, Ethernet0/1
D        10.6.6.6 [90/460800] via 192.168.13.3, 00:02:17, Ethernet0/1
                  [90/460800] via 192.168.12.2, 00:02:17, Ethernet0/0
D     192.168.24.0/24 [90/307200] via 192.168.12.2, 00:12:05, Ethernet0/0
D     192.168.35.0/24 [90/307200] via 192.168.13.3, 00:11:26, Ethernet0/1
D     192.168.46.0/24 [90/332800] via 192.168.12.2, 00:02:19, Ethernet0/0
D     192.168.56.0/24 [90/332800] via 192.168.13.3, 00:02:17, Ethernet0/1

RP3#show ip route eigrp 65002 | inc /
      10.0.0.0/32 is subnetted, 6 subnets
D        10.6.6.1 [90/409600] via 192.168.13.1, 00:12:03, Ethernet0/1
D        10.6.6.2 [90/435200] via 192.168.13.1, 00:12:03, Ethernet0/1
D        10.6.6.4 [90/460800] via 192.168.35.5, 00:02:54, Ethernet0/0
                  [90/460800] via 192.168.13.1, 00:02:54, Ethernet0/1
D        10.6.6.5 [90/409600] via 192.168.35.5, 00:11:24, Ethernet0/0
D        10.6.6.6 [90/435200] via 192.168.35.5, 00:11:05, Ethernet0/0
D     192.168.12.0/24 [90/307200] via 192.168.13.1, 00:12:03, Ethernet0/1
D     192.168.24.0/24 [90/332800] via 192.168.13.1, 00:02:54, Ethernet0/1
D     192.168.46.0/24 [90/332800] via 192.168.35.5, 00:02:56, Ethernet0/0
D     192.168.56.0/24 [90/307200] via 192.168.35.5, 00:11:24, Ethernet0/0

RP4#show ip route eigrp 65002 | inc /
      10.0.0.0/32 is subnetted, 6 subnets
D        10.6.6.1 [90/486400] via 192.168.46.6, 00:02:55, Ethernet0/0
D        10.6.6.2 [90/409600] via 192.168.24.2, 00:11:47, Ethernet0/1
D        10.6.6.3 [90/460800] via 192.168.46.6, 00:02:55, Ethernet0/0
D        10.6.6.5 [90/435200] via 192.168.46.6, 00:02:55, Ethernet0/0
D        10.6.6.6 [90/409600] via 192.168.46.6, 00:02:55, Ethernet0/0
D     192.168.12.0/24 [90/307200] via 192.168.24.2, 00:11:47, Ethernet0/1
D     192.168.13.0/24 [90/332800] via 192.168.24.2, 00:02:55, Ethernet0/1
D     192.168.35.0/24 [90/332800] via 192.168.46.6, 00:02:55, Ethernet0/0
D     192.168.56.0/24 [90/307200] via 192.168.46.6, 00:02:55, Ethernet0/0

RP5#show ip route eigrp 65002 | inc /
      10.0.0.0/32 is subnetted, 6 subnets
D        10.6.6.1 [90/435200] via 192.168.35.3, 00:11:26, Ethernet0/0
D        10.6.6.2 [90/460800] via 192.168.56.6, 00:02:56, Ethernet0/1
                  [90/460800] via 192.168.35.3, 00:02:56, Ethernet0/0
D        10.6.6.3 [90/409600] via 192.168.35.3, 00:11:26, Ethernet0/0
D        10.6.6.4 [90/435200] via 192.168.56.6, 00:02:56, Ethernet0/1
D        10.6.6.6 [90/409600] via 192.168.56.6, 00:11:07, Ethernet0/1
D     192.168.12.0/24 [90/332800] via 192.168.35.3, 00:02:56, Ethernet0/0
D     192.168.13.0/24 [90/307200] via 192.168.35.3, 00:11:26, Ethernet0/0
D     192.168.24.0/24 [90/332800] via 192.168.56.6, 00:02:56, Ethernet0/1
D     192.168.46.0/24 [90/307200] via 192.168.56.6, 00:02:58, Ethernet0/1

RP6# show ip route eigrp 65002 | inc /
      10.0.0.0/32 is subnetted, 6 subnets
D        10.6.6.1 [90/460800] via 192.168.56.5, 00:11:08, Ethernet0/1
D        10.6.6.2 [90/435200] via 192.168.46.4, 00:02:57, Ethernet0/0
D        10.6.6.3 [90/435200] via 192.168.56.5, 00:11:08, Ethernet0/1
D        10.6.6.4 [90/409600] via 192.168.46.4, 00:02:57, Ethernet0/0
D        10.6.6.5 [90/409600] via 192.168.56.5, 00:11:08, Ethernet0/1
D     192.168.12.0/24 [90/332800] via 192.168.46.4, 00:02:57, Ethernet0/0
D     192.168.13.0/24 [90/332800] via 192.168.56.5, 00:02:57, Ethernet0/1
D     192.168.24.0/24 [90/307200] via 192.168.46.4, 00:02:57, Ethernet0/0
D     192.168.35.0/24 [90/307200] via 192.168.56.5, 00:02:54, Ethernet0/1


EIGRP-R3#traceroute 192.168.46.6
Type escape sequence to abort.
Tracing the route to 192.168.46.6
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.12.2 0 msec 0 msec 1 msec
  2 192.168.24.4 0 msec 1 msec 1 msec
  3 192.168.46.6 1 msec 1 msec 1 msec

EIGRP-R3#traceroute 192.168.56.6
Type escape sequence to abort.
Tracing the route to 192.168.56.6
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.13.3 0 msec 0 msec 1 msec
  2 192.168.35.5 1 msec 0 msec 1 msec
  3 192.168.56.6 1 msec 1 msec 1 msec